Important Security Update

Aug 25, 2015 3286 0 Share
Red Giant Team
Red Giant Team

We have upgraded our infrastructure in preparation for new security standards. As a result, moving forward you will need to be running Red Giant Link version 1.9.5 or higher. Your version of Link should have automatically updated to the latest version, but if not and you experience problems signing in and accessing your account information, please download the latest version of Link here.

Rest assured, these changes do not affect your ability to use our products or update them, however, you will not be able to sign in to your account with Red Giant Link 1.9.4 or earlier. We strongly recommend you update to prevent any issues in accessing your account.

As always, if you have any problems, our support team is here for you.

Post a Comment

Sign In to Post a Comment

Free

Did you know you can try Red Giant products? Trial installers are available to test things out on your system and, aside from time restrictions or watermarks, are fully functional!

Upgrade

If you have an older version of a product, you are eligible for an upgrade at a discounted price. Upgrades save you money while keeping you current.

Students & Teachers

If you are a student or teacher, you are eligible for 50% off all of our products. It takes just a few minutes to set up your academic status.

Businesses

We offer special rates and services for businesses making volume purchases of our products. Connect with us to learn more.