Trapcode Form

Base Form > 3D/OBJ Model Settings group

Go beyond grids and spheres with 3D Model support in Form 3. This option allows you to use a 3D model as the shape of the base form. This allows you to use the shape of 3D models designed in your favorite 3D applications, including Cinema 4D, Blender, 3D Studio Max and Maya. Import a static or animated 3D Model, and Form will automatically convert its vertices into particles for a fast start to a sophisticated animation.

The Choose OBJ/Model button and the 3D Model/OBJ Settings area.

You can import a 3D model or 3D sequence in several ways. After selecting the 3D Model/OBJ option from the Base Form drop down, you can import a 3D model (or sequence) with the Choose Model/OBJ… button. This opens a window that shows you the 3D files that are included with Form. You can also import your own 3D Model from here by clicking the Add New Model/OBJ… button in the upper right corner of this window.

Form ships with a large collection of 3D objects for you to use as the base form.

These sample 3D files included with Form can also be accessed through the Designer by going to Blocks > Base Form > 3D Model, and then clicking the Choose Model… button.

You can also import 3D Model files or sequences into the Project panel in After Effects, and add them to compositions manually as you would any other asset.

Note that when using 3D Model files with Form (regardless of the method used to import them), the 3D Model's layer will need to have its visibility disabled in the composition. Otherwise, a warning about the file format may be displayed.

bf3

This warning may appear on model layers, so be sure to turn off their visibility.

Form supports 3D objects with built-in features like Shading group, Layer Maps, World Transform and Motion Blur. Form integrates well into After Effects' 3D environment by working with features like 3D lights, the 3D camera and orthographic viewing.

  • Red Giant Complete users only: Trapcode Suite 15.2 adds support for Cineware (.c4d) files for use with Mir, which can be exported directly from Cinema 4D under File > Save Project for Cineware.

    • If you want to Save Polygons or Animation in your Cineware file, you can toggle these options under:
      • Cinema 4D vR21: Edit > Preferences > Files
      • Cinema 4D vR22: Edit > Project Settings > Cineware
    • For animations, these typically have best results when:
      • The animation frame rate matches the AE Composition
        • >In After Effects, this is under: Composition > Composition Settings > Frame Rate
        • In Cinema 4D, this is under: Edit > Project Settings > FPS
      • The Point Level Animation (PLA) for the objects is baked in, which can be done by following these steps:
        • Moving your objects to the Animate timeline (Layout > Animate)
        • Select the objects, then choose Functions > Bake Objects
        • Under Include, toggle PLA and Animated Parameters
        • This creates a copy of your object. Delete the original.

3D Model importing note: Form does not support negative indices (also called relative indices) inside the model's file. Indices are used to reference vertices inside the model. Also note that animated models are not supported when working with Fluid Dynamics.

3D Model pop-up: Once you have imported a 3D Model file and added it to your composition, use this menu to choose your 3D Model. 

Refresh button: When you first load your 3D Model, Form caches the animation and then uses that information instead of referencing the file itself. Once that cache is built, if any changes in the 3D Model are made, you will not see those changes in the Form animation. If you want Form to re-cache the animation, click Refresh to refresh your 3D model.

Particles From pop-up

bf6

When Form imports an 3D model, it applies particles to the edges of the 3D model. But Form 3 gives you the ability to choose to apply the particles in other ways as well.

Vertices

bf7

Setting the Particles From pop-up to Vertices will place a Form particle at each vertex on your 3D object.

Edges

bf8

Setting the Particles From pop-up to Edges will place Form particles along the edges of your 3D object.

Faces

bf9

Setting the Particles From pop-up to Faces will place Form particles on the faces (i.e. triangles/polygons/n-gons) of your 3D object.

Volume

bf10

Setting the Particles From pop-up to Volume will fill your 3D object with Form particles.

Particle Density

bf11 bf12

Left to Right, Particle Density at 17; Particle Density at 70.

When using a 3D model as your Base Form, the particle count options in the Base Form Group (e.g. Particles in X, Particles in Y, etc.) will be grayed out. This is because Form doesn’t use these particle settings to determine the number of particles on an 3D Model. Instead, the particle count is determined by the mesh of the model in conjunction with the option selected in the Particles From pop-up. Reducing the Particle Density value allows you to remove particles from the mesh, making the form less dense. Note that you can also take this value above 100% in order to add more particles.

Normalize: Normalize scales and moves the model to ensure it is centered around the Base Form position and fits within the bounding box defined by the Base Form Size parameters. If the model is animated, the first frame is used as the reference for the normalization (note animated  models are not supported when working with Fluid Dynamics).

If you turn off Normalize, your model might not be visible within the field of view or be very small or large depending on the range of coordinate values used by points in the model.

  • Red Giant Complete Users only: When this option is disabled and you’re working with a C4D file, the model is centered around coordinates defined by the C4D file. If the model is disappearing when this option is disabled, check that the imported scene aligns with the camera; the C4D coordinates may have positioned the model somewhere off screen.

    If you want your Composition to match the imported C4D scene, select the Cineware plugin on your .C4D layer and make sure Comp Camera is selected as the Project Settings Camera, then click Extract at the bottom to bring the C4D camera into your composition. This camera will have the same duration as your C4D scene (not your Composition), so it may need to be adjusted after its import.

Invert Z: Invert Z flips the model on the Z axis, turning the object to face forwards or backwards (if located at default values).

Ignore Imported UVs: 3D modeling software often includes UV mapping in the export for aligning materials on the model. This can be useful for Form in assigning order to your particles across the surface. Occasionally, these UVs cause unwanted results. If this is the case, checking ‘Ignore Imported UVs’ may give the order expected.

Sequence Speed: Controls the speed of the animation (if any). Higher values mean a faster speed. For instance, Speed at 0.5 equals 50% speed, while Speed at 2 equals 200% speed.

Sequence Offset: Animated sequences are very similar to image sequences in that an animated sequence that lasts 30 frames will contain 30 model files that it cycles through. Offset adjusts the frame the animation starts on. Instead of starting on Frame 0, with an Offset of 3, you will start at frame 3.

Loop Sequence: Toggles whether the 3D sequence animates continuously on a loop.