Red Giant BulletProof

Menu Items & Undo/Redo

The menus in BulletProof give you more ways to get your tasks done quickly.

 

File menu

The File menu has commands for creating new items: a catalog, folder and playlist. You can open catalogs from here as well.

The File menu also opens the almighty Activity Log file, which is your source for checksum information.


 

 

Edit menu for Undo/Redo

You’re used to Undo and Redo in your applications, and BulletProof doesn’t disappoint. BulletProof supports unlimited Undo/Redo, and remembers your commands between most views. You can move between Organize, Review, Refine and Refine, and undo or redo endlessly.

The exception is going between Import view and another view. Since Import doesn't support thumbnails, and your Undo/Redo will generally involve changes to the clip, the Undo/Redo memory gets reset when you go to Import.

The Undo and Redo commands work like you expect. Let’s say you copy/paste a Curves setting from one clip to 100 other clips, but then you want to remove that color adjustment. Select the Undo menu item and you're done.

The description for Undo or Redo is general. Whether you undo a Curves adjustment or Colorista 3-Way, for instance, the command will display "Undo Set Color Settings."

The following features are undoable and redoable:

  • color changes
  • metadata attributes
  • keywords
  • text field changes
  • In/Out points
  • marker creation and edits

 

 

Edit menu for Copy/Paste

The Edit menu also holds the familiar Copy/Paste commands.

The Edit> Copy menu item will copy metadata values, and is important when working with Metadata presets. The Copy command does not copy adjustments in the Color Settings panel. For color, you use the Metadata> Copy Color Settings menu item.

The Edit> Paste command will paste metadata values or color values, depending upon which were copied.

Learn more about Copy/Paste in BulletProof on this page.


 

 

Edit menu for Selection

The rest of the Edit menu has commands for selection.

  • Select All. Selects all clips in a folder, playlist or the catalog Import All will highlight unsupported files types (like JPEG and PNG) so use Select All Video Files if you need to filter.

  • Deselect or Invert. Invert that selection, or deselect all items.

  • Select By. Select files by their Label metadata: Flags, Star Rating or Color Label.

  • Select All Video Files. Let's say you have a hard drive with still images, audio files and video files. Use this command to only select the video files in a location.

  • Select All Files Not Imported. Highlights any file that is not imported anywhere in the catalog. This criteria is not based on the source selected for import. The files that have been imported will display as dark gray, so you can easily distinguish them.

    IMPORTANT: Currently this option works with media cards if you go back to the card immediately after an import. It does not yet support external, internal or network drives.

 

 

Metadata menu

The Metadata menu has options for setting Labels, Markers and Keywords. You can also apply Label features by context-clicking on a clip thumbnail, or by using the Metadata panel.

Export Color Settings as LUT lets you save color adjustments as a LUT file. You can also do this through the Preset menu in the Color Settings panel.

There is a command for Copy Color Settings, which copies all color adjustments on a clip. Use the Edit> Paste menu item, or the Paste Color Settings context-command, to paste the color values.


 

View menu

The View menu has options for how you view the catalog and its clips.

You can switch between the five BulletProof views—and don't forget the keyboard shortcuts for doing this! You can change between the two Playback previews, which are Actual Size and Best Fit.

There are two submenus for organizing the display of your imported media. This grouping/sorting doesn't change the physical location of the clips, just how you are viewing them. Learn more in Thumbnails & File Types.

  • Group Clips By organizes your view of all clips in a folder or catalog by group. This choice sets the group header that you see above each group, like Star Rating or the folder name.

  • Sort Clips By organizes your view of all clips within each group. The clips will show in order of their file name or file size, for instance.