Red Giant PluralEyes

System Requirements

Our tests have shown that Red Giant PluralEyes 4 performs best when used with the system configurations listed below. These are the minimum requirements that we support for PluralEyes 4. For the latest compatibility information, go to our Compatibility page.  

Macintosh Support

Mac OS 10.9 and higher. These video editors are supported with the Export Timeline options:

  • Adobe Premiere Pro CS6, CC, CC 2015, CC 2015.3, CC 2017
  • Final Cut Pro X 10.2.3 and higher
  • Video/Audio Export from PluralEyes 4 can be used with any NLE

 

Windows Support

Windows 7 and higher. 64-bit only. These video editors are supported with the Export Timeline options:

  • Adobe Premiere Pro CS6, CC, CC 2015, CC 2015.3, CC 2017
  • Sony Vegas Pro 13
  • Magix Vegas Pro 14
  • Video/Audio Export from PluralEyes 4 can be used with any NLE
  • EDIUS 7.5 and higher