Trapcode Particular

Emitter Group > 3D/OBJ Model Emitter Group

This parameter lets you emit particles from 3D models. This allows you to use 3D objects from your favorite 3D applications as the shape of your emitter.

Using a 3D object as an emitter can create some very complex and powerful results, including creating the look of a three-dimensional object being created out of particles.

Importing Models

There are two ways to bring in 3D models. After selecting the 3D Model option from the Emitter pop-up, you can import a 3D file (or sequence) with the Choose Model/OBJ button. This opens a window that shows you the models that are included with Particular. You can also import your own models from here by clicking the Add New Model/OBJ button in the upper right corner of this window.

These sample 3D files included with Particular can also be accessed through the Designer by going to Blocks > Emitter Type > 3D Model/OBJs, and then clicking the Choose Model/OBJ button in the Block controls. For more information on the models files included with Particular and this window, consult the Using Presets page.

You can also import models or animated 3D sequence into the Project panel in After Effects, and add them to compositions manually as you would any other asset.

  • Red Giant Complete users only: Trapcode Suite 15.2 adds support for Cineware (.c4d) files for use with Particular, which can be exported directly from Cinema 4D under File > Save Project for Cineware.

    • If you want to Save Polygons or Animation in your Cineware file, you can toggle these options under:
      • Cinema 4D vR21: Edit > Preferences > Files
      • Cinema 4D vR22: Edit > Project Settings > Cineware
    • For animations, these typically have best results when:
      • The animation frame rate matches the AE Composition
        • >In After Effects, this is under: Composition > Composition Settings > Frame Rate
        • In Cinema 4D, this is under: Edit > Project Settings > FPS
      • The Point Level Animation (PLA) for the objects is baked in, which can be done by following these steps:
        • Moving your objects to the Animate timeline (Layout > Animate)
        • Select the objects, then choose Functions > Bake Objects
        • Under Include, toggle PLA and Animated Parameters
        • This creates a copy of your object. Delete the original.

Note that when using 3D model files with Particular (regardless of the method used to import them), the model's layer will need to have its visibility disabled in the composition. Otherwise, a warning about the file format may be displayed.

image18

Note: Form does not support negative indices (also called relative indices) inside the model. Indices are used to reference vertices inside the 3D model file.

3D Model/OBJ Emitter Settings

With your Emitter Type set to 3D/OBJ Model, the settings in the 3D Model/OBJ Emitter area will become available. These give you more options for customizing the way your particles look.

3D Model pop-up

Once you have imported an model and added it to your composition, use this menu to choose its layer.

Refresh button

When you first load a model, Particular caches the animation and then uses that information instead of referencing the model directly. Once that model's cache is built, if any changes in the model file are made, you will not see those changes in the Particular animation. If you want Particular to re-cache the animation, click Refresh to refresh your model.

Emit From pop-up

The Emit From pop-up determines which component of your 3D model will be emitting particles.

image12

Vertices

image11

Setting the Emit From pop-up to Vertices will edit from the vertices of your 3D object.

Edges

Setting the Emit From pop-up to Edges will place particles along the edges of your 3D object.

Faces

image14

Setting the Emit From pop-up to Faces will place particles on the faces (i.e. triangles/polygons/n-gons) of your 3D object.

Volume

image15

Setting the Emit From pop-up to Volume will cause particles to be emitted from inside the object.

Normalize

Normalize scales and moves the model to ensure it is centered around the Emitter position and fits within the bounding box defined by the Emitter Size parameters. If the model is an animated sequence, the first frame is used as the reference for the normalization.
If you turn off Normalize, your model might not be visible within the field of view or be very small or large depending on the range of coordinate values used by points in the model.

  • Red Giant Complete Users only: When this option is disabled and you’re working with a C4D file, the model is centered around coordinates defined by the C4D file. If the model is disappearing when this option is disabled, check that the imported scene aligns with the camera; the C4D coordinates may have positioned the model somewhere off screen.

    If you want your Composition to match the imported C4D scene, select the Cineware plugin on your .C4D layer and make sure Comp Camera is selected as the Project Settings Camera, then click Extract at the bottom to bring the C4D camera into your composition. This camera will have the same duration as your C4D scene (not your Composition), so it may need to be adjusted after its import.

Invert Z

Invert Z flips the model on the Z axis, turning the object to face forwards or backwards (if located at default values).

Using Animated Sequences

You can import static 3D models, or you can import an animated sequence of 3D models. This creates an animated emitter. There are two parameters that allow you more control when working with animated sequences.

Sequence Speed

Controls the speed of the 3D model's animation. Higher values mean a faster speed. For instance, Speed at 0.5 equals 50% speed, while Speed at 2 equals 200% speed.

Sequence Offset

3D model's animated sequences are very similar to image sequences. An animate sequence that lasts 30 frames contains 30 model files that it cycles through. Offset offsets the frame that the animation starts on. Instead of starting on Frame 0, with an Offset of 3, you will start at frame 3.