Universe

System Requirements

Our tests have shown that Universe performs best when used with the system configurations listed below. Although many of our products will run on older or less powerful systems, these are the minimum requirements that we support for Universe.

Supported Host Applications

  • Adobe After Effects: CC 2017 later
  • Adobe Premiere Pro: CC 2017 or later
  • Apple Final Cut Pro X: 10.2.3 or later
  • Avid Media Composer: 8.2 and later*
  • Motion: 5.3.2 or later
  • Magix Vegas Pro: 14 or later
  • HitFilm Pro: 2017 or later
  • DaVinci Resolve: 14 or later

Required Video Memory

  • 2GB of dedicated VRAM is needed for HD projects (up to 1920x1080)
  • 4GB of dedicated VRAM is necessary for 4k projects or high resolution imagery

Dedicated VRAM Requirements are multiplied by the number of monitors you've got attached (2 monitors requires 4GB of VRAM for HD, 8GB for 4k; 3 monitors requires 6GB of VRAM for HD, etc.)

*Prism Displacement, Compound Blur, and Picture in Picture are not supported in Avid Media Composer

For up to date compatibility information please visit our compatibility page.